firmware

MMI 2G High – MMI Hungarian Language pack!

We would like to announce that we have now available Hungarian language pack for MMI 2G High.

It only works with already installed firmware version 5.5.70 – if you don’t have, you must install it before doing this conversion.

Link for conversion (click).

Link for firmware 5.5.70 (click).

Installation looks same like installation of newest firmware, need to burn iso file on to CD and enter engineering menu.

More information about installation you can find here.

0 Comments
Inline Feedbacks
View all comments